Dynamic Trend Software Download

Minimum requirements:
Windows 7, Windows 8, Windows 10 (32bit or 64bit)
Intel® Core™ i3 / i5 / i7
4 GB RAM
250 MB available disk space
DSL or cable modem


Dynamic Trend for Quotestream Connect - Version 2.2.24

Download the latest version of Dynamic Trend. This version supports the Quotestream Connect data feed. Contact support if you are not sure what feed you need.

Dynamic Trend for Tradier Brokerage - Version 2.2.24

You will need a funded Tradier Brokerage account to be able to connect to the Tradier data feed. Go to www.tradierbrokerage.com for more information.

Dynamic Trend for eSignal - Version 2.2.26

Download the latest version of Dynamic Trend. This version supports the eSignal data feed. This download is for all market exchange options. Contact support if you are not sure what feed you need.